CVE-2024-47670: Linux kernel · ocfs2: add bounds checking to ocfs2_xattr_find_entry()
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 5.4.0-1142.152~18.04.1 : patch Linux kernel soon.
Data as of 26 Oct 2026, 23:44 UTC
- Patch
- Available – fixed in 5.4.0-1142.152~18.04.1, 5.4.0-1145.152~18.04.1, 5.4.0-1143.152~18.04.1 +76
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 9 Oct 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-7166-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7166-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7166-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7186-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7186-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7194-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7166-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7293-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7294-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7295-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7301-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7303-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azure-nvidiapkg:deb/ubuntu/linux-azure-nvidia?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released by the Linux kernel maintainers and Ubuntu security team. Users should update to the fixed kernel versions listed in the established facts, such as 5.4.0-1142.152~18.04.1 and later. Applying these official kernel updates will remediate the vulnerability. No additional mitigations are required beyond applying the vendor-provided patches.
Description
CVE-2024-47670 is a high-severity vulnerability in the Linux kernel's ocfs2 filesystem code. It involves missing bounds checking in the ocfs2_xattr_find_entry() function, which could lead to out-of-bounds memory access when processing crafted filesystem images. This flaw has been addressed by adding a paranoia check to ensure scanning does not exceed valid memory regions containing extended attribute entries. Multiple Linux kernel versions are affected, and patches have been released to fix the issue.
References
- ubuntu.com/security/CVE-2024-47670 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-47670 (opens in a new tab)
- git.kernel.org/stable/c/9b32539590a8e6400ac2f6e7cf9cbb8e08711a2f (opens in a new tab)
- git.kernel.org/stable/c/1f6e167d6753fe3ea493cdc7f7de8d03147a4d39 (opens in a new tab)
- git.kernel.org/stable/c/8e7bef408261746c160853fc27df3139659f5f77 (opens in a new tab)
- git.kernel.org/stable/c/9e3041fecdc8f78a5900c3aa51d3d756e73264d6 (opens in a new tab)
- ubuntu.com/security/notices/USN-7166-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7166-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7166-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7186-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7186-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7194-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7166-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7293-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7294-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7295-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7301-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7303-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7304-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7294-2 (opens in a new tab)