CVE-2024-48624: domainmod · Cross-site Scripting
Affects domainmodSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.12.0 when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.12.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 15 Oct 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade domainmod/domainmod to 4.12.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubdomainmod/domainmodpkg:github/domainmod/domainmodOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2024-48624, organizations should immediately upgrade DomainMOD to version 4.12.0 or later, where the vulnerability is fixed. If upgrading is not immediately possible, implement strict input validation on the 'segid' parameter to allow only expected numeric or alphanumeric values, rejecting any suspicious input. Apply proper output encoding/escaping on all reflected parameters to prevent script execution in the browser. Employ Content Security Policy (CSP) headers to restrict the execution of inline scripts and reduce the impact of XSS attacks. Additionally, enforce the principle of least privilege for DomainMOD users to limit the damage potential of compromised accounts. Regularly monitor web application logs for suspicious GET requests containing unusual 'segid' values. Finally, educate users about the risks of clicking on untrusted links, especially within authenticated sessions.
Description
In segments\edit.php of DomainMOD below v4.12.0, the segid parameter in the GET request can be exploited to cause a reflected Cross Site Scripting (XSS) vulnerability.