Skip to main content
VulnerabilityPublished

CVE-2024-4867: WSO2 API Manager · Cross-site Scripting

Affects WSO2 API ManagerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.4 Medium · fixed in 4.1.0.187 : update WSO2 API Manager when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.1.0.187, 4.0.0.293, 3.2.1.32 +1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade WSO2 API Manager to 4.1.0.187, 4.0.0.293, 3.2.1.32 or 3.2.0.408.

Affected software

ProductAffectedFixed in
WSO2WSO2 API ManagerAffected
  • >=4.1.0 <4.1.0.187
Fixed in
  • 4.1.0.187
WSO2WSO2 API ManagerAffected
  • >=4.0.0 <4.0.0.293
Fixed in
  • 4.0.0.293
WSO2WSO2 API ManagerAffected
  • >=3.2.1 <3.2.1.32
Fixed in
  • 3.2.1.32
WSO2WSO2 API ManagerAffected
  • >=3.2.0 <3.2.0.408
Fixed in
  • 3.2.0.408

AI-suggested

If you cannot patch yet, users should exercise caution when interacting with the developer portal and avoid clicking on suspicious links or inputs. No vendor-provided mitigation or temporary fix is currently documented.

Description

The WSO2 API Manager developer portal accepts user-supplied input without enforcing expected validation constraints or proper output encoding. This deficiency allows a malicious actor to inject script content that is executed within the context of a user's browser. By leveraging this cross-site scripting vulnerability, a malicious actor can cause the browser to redirect to a malicious website, make changes to the UI of the web page, or retrieve information from the browser. However, session hijacking is not possible as all session-related sensitive cookies are protected by the httpOnly flag.

References

Community reviews

Loading reviews…