Skip to main content
VulnerabilityPublished Updated

CVE-2024-49593: Advanced Custom Fields · Cross-site Scripting

Source CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium · fixed in 6.3.9 : update affected systems when convenient.

Data as of 26 Oct 2026, 16:39 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.3.9, 6.3.6.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Oct 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

AI-suggested

  1. Immediately update Advanced Custom Fields to version 6.3.9 or later and Secure Custom Fields to version 6.3.6.3 or later to apply the official patches addressing this vulnerability.
  2. For users of the free ACF version on WP Engine, follow the vendor's documented alternative update mechanism to ensure timely patching.
  3. Restrict access to the Field Group editor interface to trusted administrators only, using role-based access controls and IP whitelisting where possible.
  4. Implement Web Application Firewall (WAF) rules to detect and block suspicious input patterns that may indicate XSS payloads targeting these plugins.
  5. Conduct regular security audits and monitoring of WordPress admin activity logs to detect unusual behavior or unauthorized field edits.
  6. Educate site administrators about the risks of stored XSS and encourage cautious handling of plugin field content.
  7. Consider employing Content Security Policy (CSP) headers to limit the execution of unauthorized scripts in the WordPress admin area.
  8. Backup WordPress sites regularly to enable quick recovery in case of compromise. These steps collectively reduce the risk of exploitation and limit potential damage from this vulnerability.

Description

In Advanced Custom Fields (ACF) before 6.3.9 and Secure Custom Fields before 6.3.6.3 (plugins for WordPress), using the Field Group editor to edit one of the plugin's fields can result in execution of a stored XSS payload. NOTE: if you wish to use the WP Engine alternative update mechanism for the free version of ACF, then you can follow the process shown at the advancedcustomfields.com blog URL within the References section below.

References

Community reviews

Loading reviews…