Skip to main content
VulnerabilityPublished Updated

CVE-2024-50007: Linux kernel · ALSA: asihpi: Fix potential OOB array access ASIHPI driver stores some values in the

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.8 High · fixed in 5.4.0-1142.152~18.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 23:31 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.4.0-1142.152~18.04.1, 5.4.0-1145.152~18.04.1, 5.4.0-1143.152~18.04.1 +80
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-54.56
Fixed in
  • 6.8.0-54.56
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1023.25
Fixed in
  • 6.8.0-1023.25
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1025.30
Fixed in
  • 6.8.0-1025.30
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threatsAffected
  • <6.11.0-1012.12~24.04.1
Fixed in
  • 6.11.0-1012.12~24.04.1
Ubuntu 24.04 LTSlinux-azure-nvidiapkg:deb/ubuntu/linux-azure-nvidia?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1014.15
Fixed in
  • 6.8.0-1014.15
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1024.26
Fixed in
  • 6.8.0-1024.26

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. The vulnerability is fixed in Linux kernel versions 5.4.0-1142.152~18.04.1 and later. Users and administrators should update their systems to these or newer kernel versions as provided by their Linux distribution vendors. No additional mitigations are indicated by the vendor advisory.

Description

CVE-2024-50007 is a high-severity vulnerability in the Linux kernel's ALSA asihpi driver that could lead to out-of-bounds (OOB) array access. The issue arises because the driver stores values in a static array using an index derived from firmware responses without proper validation. A patch has been released that adds a sanity check to ensure the array index is within bounds, preventing potential memory corruption.

References

Community reviews

Loading reviews…