CVE-2024-50343: symfony · Improper Input Validation
Affects symfonySource GCVE Database
Not known to be exploited · CVSS 3.1 Low · fixed in 7.1.4 : update symfony when convenient.
Data as of 30 Oct 2026, 00:05 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 3.1 |
|---|
- Patch
- Available – fixed in 7.1.4, 6.4.11, 5.4.43
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade symfony to 7.1.4, 6.4.11 or 5.4.43.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| symfony symfony | Affected
| Fixed in
|
AI-suggested
Upgrade symfony/validator to version 5.4.43, 6.4.11, or 7.1.4 or later where the issue is fixed by applying the D regex modifier. There are no known workarounds for this vulnerability, so upgrading is the recommended and only effective mitigation.
Description
CVE-2024-50343 is an improper input validation vulnerability in the symfony/validator component of the Symfony PHP framework. The issue allows bypassing a Validator configured with regular expressions using the $ metacharacter when the input ends with a newline character. This flaw affects versions prior to 5.4.43, 6.4.11, and 7.1.4. The vulnerability has been fixed by introducing the D regex modifier to ensure the entire input is matched.