Skip to main content
VulnerabilityPublished

CVE-2024-51092: librenms · CVE-2024-51092 is a critical remote code execution

Affects librenmsSource CVE Database V5

0

Public exploit available (Metasploit) · CVSS 9.1 Critical : upgrade to 24.10.0 as a priority.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
7.1% chance of exploitation in 30 days – higher than 94% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 24.10.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    1 Metasploit module

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade librenms/librenms to 24.10.0.

Affected software

ProductAffectedFixed in
GitHublibrenms/librenmspkg:github/librenms/librenmsOther threatsAffected
  • <24.10.0
Fixed in
  • 24.10.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict access to the affected LibreNMS installation to trusted users only and monitor for suspicious activity related to the affected PHP components. Avoid exposing the service directly to untrusted networks.

Description

CVE-2024-51092 is a critical remote code execution vulnerability in LibreNMS versions before 24.10.0. It involves OS command injection through specific PHP files: AboutController.php's index(), SettingsController.php's update(), and PollDevice.php's initRrdDirectory(). The vulnerability allows an attacker with low privileges to execute arbitrary code without user interaction. The CVSS score is 9.1, indicating a high severity with significant confidentiality, integrity, and availability impacts.

References

Community reviews

Loading reviews…