CVE-2024-51567: CyberPersons CyberPanel · Missing Authentication
Affects CyberPersons CyberPanelSource CVE Database V5
Exploited in the wild · used in ransomware campaigns · KEV due 28 Nov 2024 · public exploit available (Metasploit) · 84% EPSS : apply the vendor's fix or mitigations to CyberPersons CyberPanel now.
Data as of 26 Oct 2026, 14:05 UTC
- KEV deadline
- US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
- Ransomware
- Used in ransomware campaigns
- EPSS
- 84.4% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AC:L/AV:N/A:H/C:H/I:H/PR:N/S:C/UI:NExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 29 Oct 2024
Detectable: evidence found.
nuclei template: CyberPanel v2.3.6 Pre-Auth Remote Code Execution
Weaponised: evidence found.
Exploited in the wildExploited: evidence found.
Listed in CISA KEV 9 days after disclosure
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE published
on cve.org
, t = 0
Added to CISA KEV (opens in a new tab)
exploitation confirmed · ransomware use known
, 9 days after disclosure
KEV remediation due
US federal deadline
, 30 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubusmannasir/cyberpanelpkg:github/usmannasir/cyberpanelOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.
References
- cwe.mitre.org/data/definitions/78.html (opens in a new tab)
- dreyand.rs/code/review/2024/10/27/what-are-my-options-cyberpanel-v236-pre-auth-rce (opens in a new tab)
- github.com/usmannasir/cyberpanel/commit/5b08cd6d53f4dbc2107ad9f555122ce8b0996515 (opens in a new tab)
- cyberpanel.net/KnowledgeBase/home/change-logs/ (opens in a new tab)
- cwe.mitre.org/data/definitions/420.html (opens in a new tab)
- cyberpanel.net/blog/detials-and-fix-of-recent-security-issue-and-patch-of-cyberpanel (opens in a new tab)
- bleepingcomputer.com/news/security/massive-psaux-ransomware-attack-targets-22-000-cyberpanel-instances/ (opens in a new tab)
- cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-51567 (opens in a new tab)