CVE-2024-51653: UPDATE NOTIFICATIONS (WordPress plugin) · Cross-Site Request Forgery (CSRF)
Affects UPDATE NOTIFICATIONS (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 7.1 High.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 19 Nov 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| akira1891 UPDATE NOTIFICATIONS | Affected
| Fixed in– |
AI-suggested
Until an official fix is available, users should consider disabling or limiting use of the affected plugin to reduce risk. Implementing CSRF protections and input validation may help mitigate impact but are not confirmed as fixes for this issue.
Description
Cross-Site Request Forgery (CSRF) vulnerability in akira1891 UPDATE NOTIFICATIONS update-notifications allows Stored XSS.This issue affects UPDATE NOTIFICATIONS: from n/a through <= 0.3.4.