CVE-2024-53214: Linux kernel · vfio/pci: Properly hide first-in-list PCIe extended capability
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 4.15.0-1208.223~14.04.1 : patch Linux kernel soon.
Data as of 28 Oct 2026, 11:13 UTC
- Patch
- Available – fixed in 4.15.0-1208.223~14.04.1, 4.15.0-1198.211~16.04.1, 4.15.0-1208.223~16.04.1 +98
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Dec 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-7276-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7277-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7310-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7388-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7389-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7390-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7391-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7392-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7393-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azure-nvidiapkg:deb/ubuntu/linux-azure-nvidia?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
In the Linux kernel, the following vulnerability has been resolved: vfio/pci: Properly hide first-in-list PCIe extended capability There are cases where a PCIe extended capability should be hidden from the user. For example, an unknown capability (i.e., capability with ID greater than PCI_EXT_CAP_ID_MAX) or a capability that is intentionally chosen to be hidden from the user. Hiding a capability is done by virtualizing and modifying the 'Next Capability Offset' field of the previous capability so it points to the capability after the one that should be hidden. The special case where the first capability in the list should be hidden is handled differently because there is no previous capability that can be modified. In this case, the capability ID and version are zeroed while leaving the next pointer intact. This hides the capability and leaves an anchor for the rest of the capability list. However, today, hiding the first capability in the list is not done properly if the capability is unknown, as struct vfio_pci_core_device->pci_config_map is set to the capability ID during initialization but the capability ID is not properly checked later when used in vfio_config_do_rw(). This leads to the following warning [1] and to an out-of-bounds access to ecap_perms array. Fix it by checking cap_id in vfio_config_do_rw(), and if it is greater than PCI_EXT_CAP_ID_MAX, use an alternative struct perm_bits for direct read only access instead of the ecap_perms array. Note that this is safe since the above is the only case where cap_id can exceed PCI_EXT_CAP_ID_MAX (except for the special capabilities, which are already checked before). [1] WARNING: CPU: 118 PID: 5329 at drivers/vfio/pci/vfio_pci_config.c:1900 vfio_pci_config_rw+0x395/0x430 [vfio_pci_core] CPU: 118 UID: 0 PID: 5329 Comm: simx-qemu-syste Not tainted 6.12.0+ #1 (snip) Call Trace: <TASK> ? show_regs+0x69/0x80 ? __warn+0x8d/0x140 ? vfio_pci_config_rw+0x395/0x430 [vfio_pci_core] ? report_bug+0x18f/0x1a0 ? handle_bug+0x63/0xa0 ? exc_invalid_op+0x19/0x70 ? asm_exc_invalid_op+0x1b/0x20 ? vfio_pci_config_rw+0x395/0x430 [vfio_pci_core] ? vfio_pci_config_rw+0x244/0x430 [vfio_pci_core] vfio_pci_rw+0x101/0x1b0 [vfio_pci_core] vfio_pci_core_read+0x1d/0x30 [vfio_pci_core] vfio_device_fops_read+0x27/0x40 [vfio] vfs_read+0xbd/0x340 ? vfio_device_fops_unl_ioctl+0xbb/0x740 [vfio] ? __rseq_handle_notify_resume+0xa4/0x4b0 __x64_sys_pread64+0x96/0xc0 x64_sys_call+0x1c3d/0x20d0 do_syscall_64+0x4d/0x120 entry_SYSCALL_64_after_hwframe+0x76/0x7e
References
- ubuntu.com/security/CVE-2024-53214 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-53214 (opens in a new tab)
- git.kernel.org/linus/fe4bf8d0b6716a423b16495d55b35d3fe515905d (opens in a new tab)
- git.kernel.org/stable/c/06f2fcf49854ad05a09d09e0dbee6544fff04695 (opens in a new tab)
- git.kernel.org/stable/c/0918f5643fc6c3f7801f4a22397d2cc09ba99207 (opens in a new tab)
- git.kernel.org/stable/c/1ef195178fb552478eb2587df4ad3be14ef76507 (opens in a new tab)
- git.kernel.org/stable/c/4464e5aa3aa4574063640f1082f7d7e323af8eb4 (opens in a new tab)
- git.kernel.org/stable/c/6c6502d944168cbd7e03a4a08ad6488f78d73485 (opens in a new tab)
- git.kernel.org/stable/c/7d121f66b67921fb3b95e0ea9856bfba53733e91 (opens in a new tab)
- git.kernel.org/stable/c/949bee8065a85a5c6607c624dc05b5bc17119699 (opens in a new tab)
- git.kernel.org/stable/c/9567bd34aa3b986736c290c5bcba47e0182ac47a (opens in a new tab)
- git.kernel.org/stable/c/fe4bf8d0b6716a423b16495d55b35d3fe515905d (opens in a new tab)
- ubuntu.com/security/notices/USN-7276-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7277-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7310-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7388-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7389-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7390-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-2 (opens in a new tab)