Skip to main content
VulnerabilityPublished Updated

CVE-2024-53376: CyberPanel · OS Command Injection

Affects CyberPanelSource CVE Database V5

0

Not known to be exploited · 10% EPSS · CVSS 8.8 High : upgrade to 2.3.8 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
10.8% chance of exploitation in 30 days – higher than 95% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.3.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Dec 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade thottysploity/CyberPanel to 2.3.8.

Affected software

ProductAffectedFixed in
GitHubthottysploity/CyberPanelpkg:github/thottysploity/CyberPanelOther threatsAffected
  • <2.3.8
Fixed in
  • 2.3.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2024-53376, organizations should immediately upgrade CyberPanel to version 2.3.8 or later once available. If you cannot patch yet, restrict access to the CyberPanel interface to trusted IP addresses and enforce strong authentication mechanisms, including multi-factor authentication (MFA). Conduct thorough credential audits to ensure no compromised accounts exist. Implement web application firewalls (WAFs) with custom rules to detect and block suspicious input patterns involving shell metacharacters in the phpSelection parameter. Monitor logs for unusual command execution attempts or anomalous activity related to the websites/submitWebsiteCreation URI. Employ network segmentation to limit the impact of a potential compromise. Additionally, review and harden server configurations to minimize the privileges of the CyberPanel service user, reducing the potential damage from command injection. Regularly back up critical data and test restoration procedures to ensure resilience against potential attacks.

Description

CyberPanel before 2.3.8 allows remote authenticated users to execute arbitrary commands via shell metacharacters in the phpSelection field to the websites/submitWebsiteCreation URI.

References

Community reviews

Loading reviews…