CVE-2024-53900: mongoose · SQL Injection
Affects mongooseSource CVE Database V5
Not known to be exploited · public detection template (Nuclei) · CVSS 9.1 Critical : upgrade to 8.8.3 as a priority.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 3.9% chance of exploitation in 30 days – higher than 90% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.8.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Dec 2024
Detectable: evidence found.
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade mongoose to 8.8.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
npmmongoosepkg:npm/mongooseOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2024-53900, organizations should take the following specific actions: 1) Upgrade Mongoose to version 8.8.3 or later as soon as the patch is officially released to ensure the vulnerability is addressed. 2) Implement strict input validation and sanitization for any user-supplied data that may be used in queries, especially those involving the $where operator or other JavaScript execution contexts. 3) Avoid using the $where operator in queries where possible, or restrict its usage to trusted inputs only. 4) Employ application-layer query filtering and access controls to limit the scope of queries and prevent injection. 5) Monitor application logs and database query patterns for unusual or unexpected $where usage that could indicate exploitation attempts. 6) Conduct security code reviews and penetration testing focused on injection vulnerabilities in database queries. 7) Educate development teams about the risks of query injection and secure coding practices related to MongoDB and Mongoose. These targeted measures go beyond generic advice by focusing on the specific vector and context of this vulnerability.
Description
Mongoose before 8.8.3 can improperly use $where in match, leading to search injection.
References
- npmjs.com/package/mongoose?activeTab=versions (opens in a new tab)
- github.com/Automattic/mongoose/releases (opens in a new tab)
- github.com/Automattic/mongoose/blob/master/CHANGELOG.md (opens in a new tab)
- github.com/Automattic/mongoose/commit/c9e86bff7eef477da75a29af62a06d41a835a156 (opens in a new tab)
- github.com/advisories/GHSA-m7xq-9374-9rvx (opens in a new tab)