Skip to main content
VulnerabilityPublished Updated

CVE-2024-55956: Cleo Multiple Products · Command Injection

Affects Cleo Multiple ProductsSource CVE Database V5

0

Exploited in the wild · used in ransomware campaigns · KEV due 7 Jan 2025 · public exploit available (Metasploit) · 93% EPSS : upgrade to 5.8.0.24 now.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
Ransomware
Used in ransomware campaigns
EPSS
93.9% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.8.0.24
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 13 Dec 2024

  2. Weaponised: evidence found.

    1 Metasploit module

  3. Exploited in the wild: evidence found.

    Listed in CISA KEV 4 days after disclosure

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE published

    on cve.org

    , t = 0

  2. Added to CISA KEV (opens in a new tab)

    exploitation confirmed · ransomware use known

    , 4 days after disclosure

  3. KEV remediation due

    US federal deadline

    , 25 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Cleo Multiple Products to 5.8.0.24.

Affected software

ProductAffectedFixed in
Cleo Multiple ProductsAffected
  • <5.8.0.24
Fixed in
  • 5.8.0.24

Description

CVE-2024-55956 affects Cleo Harmony, VLTrader, and LexiCom products prior to version 5.8.0.24. The vulnerability allows an unauthenticated attacker to import and execute arbitrary Bash or PowerShell commands on the host system by exploiting the default settings of the Autorun directory. This can lead to full system compromise. The vulnerability has a critical CVSS score of 9.8 and is known to be exploited in the wild, including use in ransomware campaigns.

References

Community reviews

Loading reviews…