CVE-2024-5628: Avada (Fusion) Builder (WordPress plugin) · Cross-site Scripting
Affects Avada (Fusion) Builder (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.4 Medium · fixed in 3.11.9 : update Avada (Fusion) Builder (WordPress plugin) when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.11.9
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Sep 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| themefusion Avada (Fusion) Builder | Affected
| Fixed in– |
AI-suggested
Users should upgrade to Avada (Fusion) Builder version 3.11.10 or later, where additional hardening against this vulnerability has been implemented. Since the vulnerability was only partially fixed in 3.11.9, relying on that version alone is insufficient. Until upgrading, restrict contributor-level access to trusted users only.
Description
The Avada | Website Builder For WordPress & eCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's fusion_button shortcode in all versions up to, and including, 3.11.9 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability was partially fixed in 3.11.9. Additional hardening for alternate attack vectors was added to version 3.11.10.