CVE-2024-57910: Linux kernel · iio: light: vcnl4035: fix information leak in triggered buffer
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.1 High · fixed in 5.4.0-1142.152~18.04.1 : patch Linux kernel soon.
Data as of 29 Oct 2026, 22:45 UTC
- Patch
- Available – fixed in 5.4.0-1142.152~18.04.1, 5.4.0-1147.154~18.04.1, 5.4.0-1145.154~18.04.1 +84
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Jan 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-7379-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7380-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7381-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7382-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7388-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7389-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7390-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7391-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7392-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azure-nvidiapkg:deb/ubuntu/linux-azure-nvidia?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading to Linux kernel versions 5.4.0-1142.152~18.04.1 or later as listed in the fixed versions. The vendor advisory from Ubuntu confirms that this issue is fixed in these releases. Users should update their systems accordingly to mitigate the vulnerability.
Description
CVE-2024-57910 is a vulnerability in the Linux kernel's iio: light: vcnl4035 driver where an uninitialized buffer leads to an information leak. The issue arises because a local array used to push data to userspace does not initialize all bytes, potentially exposing uninitialized kernel memory. This flaw has been fixed in Linux kernel versions 5.4.0-1142.152~18.04.1 and later.
References
- ubuntu.com/security/CVE-2024-57910 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-57910 (opens in a new tab)
- git.kernel.org/linus/47b43e53c0a0edf5578d5d12f5fc71c019649279 (opens in a new tab)
- git.kernel.org/stable/c/47b43e53c0a0edf5578d5d12f5fc71c019649279 (opens in a new tab)
- git.kernel.org/stable/c/47d245be86492974db3aeb048609542167f56518 (opens in a new tab)
- git.kernel.org/stable/c/a15ea87d4337479c9446b5d71616f4668337afed (opens in a new tab)
- git.kernel.org/stable/c/f6fb1c59776b4263634c472a5be8204c906ffc2c (opens in a new tab)
- ubuntu.com/security/notices/USN-7379-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7380-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7381-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7382-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7388-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7389-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7390-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7391-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7392-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7393-1 (opens in a new tab)