Skip to main content
VulnerabilityPublished Updated

CVE-2024-57973: Linux kernel · rdma/cxgb4: Prevent potential integer overflow on 32bit

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 8.1 High · fixed in 5.4.0-1146.156~18.04.1 : patch Linux kernel soon.

Data as of 28 Oct 2026, 13:16 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.4.0-1146.156~18.04.1, 5.4.0-1151.158~18.04.1, 5.4.0-1149.158~18.04.1 +84
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Feb 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-64.67
Fixed in
  • 6.8.0-64.67
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1032.34
Fixed in
  • 6.8.0-1032.34
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1034.39
Fixed in
  • 6.8.0-1034.39
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threatsAffected
  • <6.11.0-1015.15~24.04.1
Fixed in
  • 6.11.0-1015.15~24.04.1
Ubuntu 24.04 LTSlinux-azure-nvidiapkg:deb/ubuntu/linux-azure-nvidia?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1022.23
Fixed in
  • 6.8.0-1022.23
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1033.35
Fixed in
  • 6.8.0-1033.35

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released by Ubuntu and other Linux distributors. Users should update their Linux kernel to the fixed versions listed (e.g., 5.4.0-1146.156~18.04.1 and later) and reboot systems to apply the fix. No additional mitigation steps are required beyond applying the official kernel updates.

Description

CVE-2024-57973 is a high severity vulnerability in the Linux kernel's rdma/cxgb4 driver where an integer overflow can occur on 32-bit systems. The flaw arises because the user-controlled variable gl->tot_len is added to other structure sizes without proper overflow checks, potentially causing an integer wraparound. This issue has been fixed by using safe addition functions to prevent overflow. Multiple Linux kernel versions prior to the fixed releases are affected. A patch is available and should be applied to mitigate the risk.

References

Community reviews

Loading reviews…