CVE-2024-58351: Flowise · Code Injection
Affects FlowiseSource GCVE Database
Not known to be exploited · CVSS 9.3 Critical : upgrade to 2.1.4 as a priority.
Data as of 27 Oct 2026, 20:42 UTC
- Patch
- Available – fixed in 2.1.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Flowise to 2.1.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Flowise Flowise | Affected
| Fixed in
|
AI-suggested
A fix is available in Flowise version 2.1.4 and later. Users should upgrade to version 2.1.4 or newer to remediate this vulnerability. No other mitigations are indicated by the vendor advisory.
Description
Flowise versions before 2.1.4 contain a critical code injection vulnerability via the overrideConfig option, which is enabled by default. This flaw allows attackers to inject configuration into the Chainflow during execution, leading to remote code execution, sandbox escape, denial of service, server-side request forgery, prompt injection, and data exfiltration. The vulnerability affects both the frontend web integration and the backend Prediction API. Exploitation impacts only the attacker’s own session and does not persist or affect other users.