CVE-2024-58360: stoatchat · Improper Use of Validation Framework
Affects stoatchatSource GCVE Database
Not known to be exploited · CVSS 6.9 Medium : upgrade to 0.7.8 when convenient.
Data as of 27 Oct 2026, 20:42 UTC
- Patch
- Available – fixed in 0.7.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade stoatchat to 0.7.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| stoatchat stoatchat | Affected
| Fixed in
|
AI-suggested
Upgrade stoatchat to version 0.7.8 or later where this vulnerability is fixed. There is no indication that this is a cloud service; therefore, remediation depends on applying the fixed version.
Description
stoatchat versions before 0.7.8 do not properly enforce account creation restrictions such as invite-only mode, email verification, captcha, and shield verification. This allows attackers to create unlimited accounts with unverified email addresses, which can increase the risk of denial-of-service attacks and compromise the integrity of the service.