CVE-2024-58390: frappe · Improper Privilege Management
Affects frappeSource GCVE Database
Not known to be exploited · CVSS 8.7 High : upgrade to 15.41.0 or 14.81.4 soon.
Data as of 27 Oct 2026, 20:28 UTC
- Patch
- Available – fixed in 15.41.0, 14.81.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 12 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade frappe/frappe to 15.41.0 or 14.81.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubfrappe/frappepkg:github/frappe/frappeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Frappe versions 14.81.4 and 15.41.0 and later. Users should upgrade to these versions to remediate the vulnerability. Since the vendor advisory or patch links are not provided, confirm patch availability and upgrade instructions from official Frappe release notes or security advisories. No alternative mitigations or workarounds are indicated.
Description
CVE-2024-58390 is an improper privilege management vulnerability in Frappe versions before 14.81.4 and 15.x before 15.41.0. It allows authenticated users with the Website User role to escalate their privileges to System Manager by exploiting a specific document action combined with additional steps. This flaw enables unauthorized administrative access within the Frappe application.