Skip to main content
CVE-2024-6000VulnerabilityPublished Updated

CVE-2024-6000: FooEvents for WooCommerce (WordPress plugin) · Improper Authorization

Affects FooEvents for WooCommerce (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 7.1 High · fixed in 1.19.20 : patch FooEvents for WooCommerce (WordPress plugin) soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.19.20
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
FooEvents FooEvents for WooCommerceAffected
  • =0
Fixed in–

AI-suggested

Users should upgrade FooEvents for WooCommerce to version 1.19.21 or later, where the vulnerability is fully patched. Versions up to 1.19.20 are vulnerable, with only a partial fix applied in 1.19.20. No other mitigations are indicated by the vendor advisory. Patch status is confirmed by the version history described in the vulnerability details.

Description

The FooEvents for WooCommerce plugin for WordPress is vulnerable to unauthorized arbitrary file uploads due to an improper capability setting on the 'display_ticket_themes_page' function in versions up to, and including, 1.19.20. This makes it possible for authenticated attackers with contributor-level capabilities or above, to upload arbitrary files on the affected site's server which may make remote code execution possible. This was partially patched in 1.19.20, and fully patched in 1.19.21.

References

Community reviews

Loading reviews…