Skip to main content
VulnerabilityPublished Updated

CVE-2024-6127: BC Security Empire · Path Traversal

Affects BC Security EmpireSource CVE Database V5

0

Public exploit available (Metasploit) · 10% EPSS · CVSS 9.8 Critical : upgrade to 5.9.3 as a priority.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
10.3% chance of exploitation in 30 days – higher than 95% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.9.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    1 Metasploit module

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade BC Security Empire to 5.9.3.

Affected software

ProductAffectedFixed in
GitHubEmpirepkg:github/EmpireOther threatsAffected
  • <5.9.3
Fixed in
  • 5.9.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in BC Security Empire version 5.9.3 and later. Users should upgrade to version 5.9.3 or newer to remediate this vulnerability. Patch status is not explicitly confirmed in the vendor advisory, but the versioning indicates that versions before 5.9.3 are vulnerable and 5.9.3 is the fixed version. Until upgraded, restrict network access to the affected service to trusted users only.

Description

BC Security Empire versions prior to 5.9.3 contain a critical path traversal vulnerability that allows remote unauthenticated attackers to execute arbitrary code. Exploitation requires completing cryptographic handshakes over HTTP and uploading payloads with malicious paths. This vulnerability is identified as CWE-22 and CWE-434 and carries a CVSS 3.1 score of 9.8, indicating critical severity.

References

Community reviews

Loading reviews…