CVE-2024-6340: Premium Addons for Elementor (WordPress plugin) · Cross-site Scripting
Affects Premium Addons for Elementor (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.4 Medium · fixed in 4.10.36 : update Premium Addons for Elementor (WordPress plugin) when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.10.36
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Jul 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets | Affected
| Fixed in– |
AI-suggested
Users should upgrade the Premium Addons for Elementor plugin to version 4.10.37 or later, where the vulnerability is fully patched. Versions up to 4.10.36 contain only a partial fix and remain vulnerable. No other mitigations are specified by the vendor advisory. Patch status is confirmed by the plugin's version history and advisory details.
Description
The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Countdown widget in all versions up to, and including, 4.10.36 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 4.10.36 and fully patched in version 4.10.37.
References
- wordfence.com/threat-intel/vulnerabilities/id/9ed80507-f3e5-45a8-9498-8cebf97155ff?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/premium-addons-for-elementor/trunk/assets/frontend/js/premium-countdown-timer.js (opens in a new tab)
- plugins.trac.wordpress.org/browser/premium-addons-for-elementor/trunk/assets/frontend/js/premium-countdown-timer.js (opens in a new tab)
- wordpress.org/plugins/premium-addons-for-elementor/ (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3115459/ (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3111117/ (opens in a new tab)