Skip to main content
VulnerabilityPublished Updated

CVE-2024-6629: All-in-One Video Gallery (WordPress plugin) · Cross-site Scripting

Affects All-in-One Video Gallery (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.4 Medium · patch available : update All-in-One Video Gallery (WordPress plugin) when convenient.

Data as of 26 Oct 2026, 15:59 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
plugins360 All-in-One Video GalleryAffected
  • =0
Fixed in–

AI-suggested

A patch is available to remediate this vulnerability. Users of the All-in-One Video Gallery plugin should update to the latest version beyond 3.7.1 where the issue is fixed. Until patched, restrict contributor-level access to trusted users only to reduce risk.

Description

The All-in-One Video Gallery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Video shortcode in all versions up to, and including, 3.7.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Community reviews

Loading reviews…