Skip to main content
CVE-2024-8353VulnerabilityPublished Updated

CVE-2024-8353: GiveWP (WordPress plugin) · Deserialization of Untrusted Data

Affects GiveWP (WordPress plugin)Source CVE Database V5

0

Mentioned vulnerabilities

Not known to be exploited · public exploit available (Metasploit) · 32% EPSS · CVSS 9.8 Critical · fixed in 3.16.1 : patch GiveWP (WordPress plugin) as a priority.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
32.3% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.16.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Sep 2024

  2. Weaponised: evidence found.

    1 Metasploit module

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
stellarwp GiveWP – Donation Plugin and Fundraising PlatformAffected
  • =0
Fixed in–

AI-suggested

The vulnerability was mostly patched in GiveWP version 3.16.1, with additional hardening in 3.16.2. Users should upgrade to at least version 3.16.2 to ensure full mitigation. No cloud service remediation applies as this is a self-hosted WordPress plugin.

Description

The GiveWP – Donation Plugin and Fundraising Platform plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 3.16.1 via deserialization of untrusted input via several parameters like 'give_title' and 'card_address'. This makes it possible for unauthenticated attackers to inject a PHP Object. The additional presence of a POP chain allows attackers to delete arbitrary files and achieve remote code execution. This is essentially the same vulnerability as CVE-2024-5932, however, it was discovered the the presence of stripslashes_deep on user_info allows the is_serialized check to be bypassed. This issue was mostly patched in 3.16.1, but further hardening was added in 3.16.2.

References

Community reviews

Loading reviews…