Skip to main content
CVE-2024-9061VulnerabilityPublished Updated

CVE-2024-9061: WP Popup Builder – Popup Forms and Marketing Lead Generation · Code Injection

Affects WP Popup Builder – Popup Forms and Marketing Lead GenerationSource CVE Database V5

0

Not known to be exploited · public detection template (Nuclei) · 52% EPSS · CVSS 7.3 High · fixed in 1.3.5 : patch WP Popup Builder – Popup Forms and Marketing Lead Generation as a priority.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
52.2% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.3.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Oct 2024

  2. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
themehunk WP Popup Builder – Popup Forms and Marketing Lead GenerationAffected
  • =0
Fixed in–

AI-suggested

Users should upgrade the WP Popup Builder plugin to version 1.3.6 or later, where the correct authorization checks have been implemented to prevent unauthorized shortcode execution. Version 1.3.5 includes a partial fix with a nonce check but does not fully resolve the issue. No other mitigations are recommended beyond applying the official update.

Description

The The WP Popup Builder – Popup Forms and Marketing Lead Generation plugin for WordPress is vulnerable to arbitrary shortcode execution via the wp_ajax_nopriv_shortcode_Api_Add AJAX action in all versions up to, and including, 1.3.5. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. NOTE: This vulnerability was partially fixed in version 1.3.5 with a nonce check, which effectively prevented access to the affected function. However, version 1.3.6 incorporates the correct authorization check to prevent unauthorized access.

References

Community reviews

Loading reviews…