CVE-2024-9347: The Ultimate WordPress Toolkit – WP Extended · Cross-site Scripting
Affects The Ultimate WordPress Toolkit – WP ExtendedSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium · fixed in 3.0.13 : update The Ultimate WordPress Toolkit – WP Extended when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.0.13
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Oct 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| wpextended The Ultimate WordPress Toolkit – WP Extended | Affected
| Fixed in– |
AI-suggested
A fix for this vulnerability is available in version 3.0.13 of The Ultimate WordPress Toolkit – WP Extended plugin. Users should upgrade to version 3.0.13 or later to remediate this issue. Versions 3.0.10 and earlier up to 3.0.9 are vulnerable, and the fix was reverted in 3.0.11, so that version should also be avoided. Patch status is confirmed by the vendor's versioning history. No additional mitigations are specified.
Description
The The Ultimate WordPress Toolkit – WP Extended plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'wpext-export' parameter in all versions up to, and including, 3.0.9 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Please note this fix was reverted in version 3.0.11 and later fixed again in version 3.0.13.
References
- wordfence.com/threat-intel/vulnerabilities/id/822c0a33-e57e-48c7-b8df-fddf3bb2e552?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/wpextended/tags/3.0.9/includes/libraries/wpext_export/wpext_export.php (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3169963/wpextended/trunk/includes/libraries/wpext_export/wpext_export.php (opens in a new tab)
- plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3220003%40wpextended&new=3220003%40wpextended&sfp_email=&sfph_mail= (opens in a new tab)