CVE-2024-9511: FluentSMTP (WordPress plugin) · Deserialization of Untrusted Data
Affects FluentSMTP (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 9.8 Critical · fixed in 2.2.82 : patch FluentSMTP (WordPress plugin) as a priority.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 1.1% chance of exploitation in 30 days – higher than 66% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.2.82
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 23 Nov 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| techjewel FluentSMTP – WP SMTP Plugin with Amazon SES, SendGrid, MailGun, Postmark, Google and Any SMTP Provider | Affected
| Fixed in– |
AI-suggested
A partial patch was introduced in version 2.2.82 of the FluentSMTP plugin. Users should update to version 2.2.82 or later to mitigate this vulnerability. Since the patch is partial, monitoring vendor advisories for further updates is recommended. Patch status is not yet fully confirmed—check the vendor advisory for current remediation guidance.
Description
The FluentSMTP – WP SMTP Plugin with Amazon SES, SendGrid, MailGun, Postmark, Google and Any SMTP Provider plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 2.2.82 via deserialization of untrusted input in the 'formatResult' function. This makes it possible for unauthenticated attackers to inject a PHP Object. No known POP chain is present in the vulnerable software. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code. The vulnerability was partially patched in version 2.2.82.
References
- wordfence.com/threat-intel/vulnerabilities/id/a3deedc4-b939-4c54-8376-95d3728872d4?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/fluent-smtp/trunk/app/Models/Logger.php (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3194359/ (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3194555/ (opens in a new tab)