Skip to main content
VulnerabilityPublished

CVE-2024-9517: WSO2 API Manager · DEPRECATED: Insufficient Session Expiration

Affects WSO2 API ManagerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.9 Medium · fixed in 4.5.0.9 : update WSO2 API Manager when convenient.

Data as of 2 Nov 2026, 11:58 UTC

CVSS 3.1 base score
4.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (WSO2)CVSS 3.14.9
Patch
Available – fixed in 4.5.0.9, 4.4.0.25, 4.3.0.62 +26
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
WSO2WSO2 API ManagerAffected
  • >=4.5.0 <4.5.0.9
Fixed in
  • 4.5.0.9
WSO2WSO2 API ManagerAffected
  • >=4.4.0 <4.4.0.25
Fixed in
  • 4.4.0.25
WSO2WSO2 API ManagerAffected
  • >=4.3.0 <4.3.0.62
Fixed in
  • 4.3.0.62
WSO2WSO2 API ManagerAffected
  • >=4.2.0 <4.2.0.149
Fixed in
  • 4.2.0.149
WSO2WSO2 API ManagerAffected
  • >=4.1.0 <4.1.0.214
Fixed in
  • 4.1.0.214
WSO2WSO2 API ManagerAffected
  • >=4.0.0 <4.0.0.315
Fixed in
  • 4.0.0.315

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in multiple versions of WSO2 API Manager, including 3.1.0.308, 3.2.0.429, 3.2.1.49, 4.0.0.315, 4.1.0.214, 4.2.0.149, 4.3.0.62, 4.4.0.25, and 4.5.0.9 and later. Users should upgrade to these fixed versions to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2024-9517 is a vulnerability in WSO2 API Manager where the refresh token grant type does not re-validate the account status before issuing new access tokens. This allows attackers to obtain valid access tokens for user accounts even after those accounts have been blocked, bypassing account lockout mechanisms. The flaw can lead to unauthorized access and potential privilege escalation or data exfiltration depending on the compromised account's permissions. The issue affects multiple versions of WSO2 API Manager prior to specific fixed releases. A fix is available in versions starting from 3.1.0.308, 3.2.0.429, 3.2.1.49, 4.0.0.315, 4.1.0.214, 4.2.0.149, 4.3.0.62, 4.4.0.25, and 4.5.0.9 and later.

References

Community reviews

Loading reviews…