Skip to main content
CVE-2025-12885VulnerabilityPublished Updated

CVE-2025-12885: Embed Any Document (WordPress plugin) · Cross-site Scripting

Affects Embed Any Document (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.4 Medium · patch available : update Embed Any Document (WordPress plugin) when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
awsmin Embed Any Document – Embed PDF, Word, PowerPoint and Excel FilesAffected
  • =0
Fixed in–

AI-suggested

A patch is available to fix this vulnerability. Users of the Embed Any Document plugin should update to the latest version beyond 2.7.10 to remediate the issue. Until patched, restrict Contributor-level access to trusted users only to reduce risk.

Description

The Embed Any Document – Embed PDF, Word, PowerPoint and Excel Files plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the sanitize_pdf_src function regex bypass in all versions up to, and including, 2.7.10 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Community reviews

Loading reviews…