Skip to main content
CVE-2025-14554VulnerabilityPublished Updated

CVE-2025-14554: Sell BTC (WordPress plugin) · Cross-site Scripting

Affects Sell BTC (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 7.2 High · fixed in 1.5 : patch Sell BTC (WordPress plugin) soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
hayyatappsSell BTC – Cryptocurrency Selling CalculatorAffected
  • <=1.5
Fixed in–

AI-suggested

No official or complete patch is currently available as per the provided data. The vulnerability was partially patched in version 1.5, but users should verify with the vendor for any updated fixes or advisories. Until a full patch is released, administrators should limit access to the Orders page to trusted users only and consider monitoring for suspicious activity.

Description

The Sell BTC - Cryptocurrency Selling Calculator plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'orderform_data' AJAX action in all versions up to, and including, 1.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in order records that will execute whenever an administrator accesses the Orders page in the admin dashboard. The vulnerability was partially patched in version 1.5.

References

Community reviews

Loading reviews…