CVE-2025-15638: ATRODO Net::Dropbear · Dependency on Vulnerable Third-Party Component
Affects ATRODO Net::DropbearSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 10.0 Critical : upgrade to 0.14 as a priority.
Data as of 29 Oct 2026, 19:04 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.14
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 21 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Net::Dropbear and Net-Dropbear to 0.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ATRODONet::Dropbear | Affected
| Fixed in
|
GitHubNet-Dropbearpkg:github/Net-DropbearOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, users should consider upgrading to Net::Dropbear version 0.14 or later if available, or manually updating the libtomcrypt dependency to a non-vulnerable version. Monitoring the vendor's communications for updates is recommended.
Description
Net::Dropbear versions before 0.14 for Perl contains a vulnerable version of libtomcrypt. Net::Dropbear versions before 0.14 includes versions of Dropbear 2019.78 or earlier. These include versions of libtomcrypt v1.18.1 or earlier, which is affected by CVE-2016-6129 and CVE-2018-12437.