CVE-2025-1736: PHP · Improper Input Validation
Affects PHPSource GCVE Database
Not known to be exploited · CVSS 6.3 Medium · fixed in 8.5.0 : update PHP when convenient.
Data as of 30 Oct 2026, 00:30 UTC
Thin evidence
One scorer or none| CNA (php) | CVSS 4.0 | 6.3 |
|---|
- Patch
- Available – fixed in 8.5.0, 8.4.5, 8.4.0 +5
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Mar 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PHP Group PHP | Affected
| Fixed in
|
AI-suggested
Upgrading PHP to the fixed versions 8.1.32, 8.2.28, 8.3.19, or 8.4.5 or later fully addresses this vulnerability. Users should apply these official fixes promptly. No additional mitigation steps are indicated by the vendor advisory.
Description
CVE-2025-1736 is an improper input validation vulnerability in PHP versions 8.1.* before 8.1.32, 8.2.* before 8.2.28, 8.3.* before 8.3.19, and 8.4.* before 8.4.5. It involves insufficient validation of end-of-line characters in user-supplied headers, which can cause certain headers to be blocked or misinterpreted.