Skip to main content
CVE-2025-1802VulnerabilityPublished Updated

CVE-2025-1802: HT Mega Addons for Elementor (WordPress plugin) · Cross-site Scripting

Affects HT Mega Addons for Elementor (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.4 Medium · fixed in 2.8.3 : update HT Mega Addons for Elementor (WordPress plugin) when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.8.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Mar 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
devitemsllc HT Mega Addons for Elementor – Elementor Widgets & Template BuilderAffected
  • =0
Fixed in–

AI-suggested

A partial patch was introduced in version 2.8.3 of the plugin. However, since the patch is partial, users should verify with the vendor or official sources whether a complete fix is available or planned. Until a full fix is confirmed, restrict Contributor-level access to trusted users only and consider additional input validation or output escaping measures.

Description

The HT Mega – Absolute Addons For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘marker_title’, 'notification_content', and 'stt_button_text' parameters in all versions up to, and including, 2.8.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.8.3.

References

Community reviews

Loading reviews…