CVE-2025-2008: WP Ultimate CSV Importer – Import CSV, XML & Excel into WordPress · Unrestricted File Upload
Affects WP Ultimate CSV Importer – Import CSV, XML & Excel into WordPressSource CVE Database V5
Not known to be exploited · CVSS 8.8 High · fixed in 7.20.1 : patch WP Ultimate CSV Importer – Import CSV, XML & Excel into WordPress soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 1.2% chance of exploitation in 30 days – higher than 68% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.20.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 Apr 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| smackcoders WP Ultimate CSV Importer – Import CSV, XML & Excel into WordPress | Affected
| Fixed in– |
AI-suggested
Upgrade the WP Ultimate CSV Importer plugin to version 7.20.1 or later, where this vulnerability has been patched. If you cannot patch yet, restrict user roles to prevent untrusted users from having Subscriber-level or higher access. Patch status is confirmed fixed in version 7.20.1; no other official mitigations are noted.
Description
The Import Export Suite for CSV and XML Datafeed plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the import_single_post_as_csv() function in all versions up to, and including, 7.19. This makes it possible for authenticated attackers, with Subscriber-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible. Please note this vulnerability was reintroduced in 7.20, and subsequently patched again in 7.20.1.