CVE-2025-21637: Linux kernel · sctp: sysctl: udp_port: avoid using current->nsproxy
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.1 High · fixed in 5.15.0-1080.87~20.04.1 : patch Linux kernel soon.
Data as of 29 Oct 2026, 22:44 UTC
- Patch
- Available – fixed in 5.15.0-1080.87~20.04.1, 5.15.0-1086.95~20.04.1, 5.15.0-1081.90~20.04.1 +62
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Jan 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-7379-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7380-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7381-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7382-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7388-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7389-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7390-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7379-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7407-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azure-nvidiapkg:deb/ubuntu/linux-azure-nvidia?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied. Fixed kernel versions include 5.15.0-1074.77~20.04.1 and later releases listed in the established facts. Users should update their Linux kernel to one of these fixed versions to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisories.
Description
CVE-2025-21637 is a high-severity vulnerability in the Linux kernel's SCTP sysctl udp_port implementation. It involves improper use of the current->nsproxy pointer, which can be NULL in some cases, leading to a null pointer dereference and potential kernel crash (Oops). The issue arises from inconsistent network namespace handling and unsafe access patterns. This flaw has been fixed in multiple Linux kernel versions starting from 5.15.0-1074.77~20.04.1 and later.
References
- ubuntu.com/security/CVE-2025-21637 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-21637 (opens in a new tab)
- git.kernel.org/linus/c10377bbc1972d858eaf0ab366a311b39f8ef1b6 (opens in a new tab)
- git.kernel.org/stable/c/55627918febdf9d71107a1e68d1528dc591c9a15 (opens in a new tab)
- git.kernel.org/stable/c/5b77d73f3be5102720fb685b9e6900e3500e1096 (opens in a new tab)
- git.kernel.org/stable/c/c10377bbc1972d858eaf0ab366a311b39f8ef1b6 (opens in a new tab)
- git.kernel.org/stable/c/e919197fb8616331f5dc81e4c3cc3d12769cb725 (opens in a new tab)
- ubuntu.com/security/notices/USN-7379-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7380-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7381-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7382-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7388-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7389-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7390-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7379-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7407-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7421-1 (opens in a new tab)