Skip to main content
VulnerabilityPublished Updated

CVE-2025-21678: Linux kernel · gtp: Destroy device along with udp socket's netns dismantle.

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.8 High · fixed in 5.4.0-1142.152~18.04.1 : patch Linux kernel soon.

Data as of 29 Oct 2026, 22:37 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.4.0-1142.152~18.04.1, 5.4.0-1147.154~18.04.1, 5.4.0-1145.154~18.04.1 +84
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Jan 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-62.65
Fixed in
  • 6.8.0-62.65
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1030.32
Fixed in
  • 6.8.0-1030.32
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1030.35
Fixed in
  • 6.8.0-1030.35
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threatsAffected
  • <6.11.0-1013.13~24.04.1
Fixed in
  • 6.11.0-1013.13~24.04.1
Ubuntu 24.04 LTSlinux-azure-nvidiapkg:deb/ubuntu/linux-azure-nvidia?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1018.19
Fixed in
  • 6.8.0-1018.19
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1031.33
Fixed in
  • 6.8.0-1031.33

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in multiple Linux kernel versions including 5.4.0-1142.152~18.04.1 and later. Users and administrators should update affected Linux kernel packages to these fixed versions or later to remediate the vulnerability. No additional mitigation steps are required beyond applying the official kernel updates.

Description

CVE-2025-21678 is a vulnerability in the Linux kernel's GTP (GPRS Tunneling Protocol) network subsystem. The flaw involves improper destruction of GTP devices when UDP socket network namespaces are dismantled, causing devices to remain alive incorrectly and leading to kernel crashes. This issue was fixed by linking the device to the socket's network namespace and updating the cleanup routine to remove all GTP devices properly. The vulnerability affects multiple Linux kernel versions and has been addressed in several patched releases.

References

Community reviews

Loading reviews…