CVE-2025-21680: Linux kernel · pktgen: Avoid out-of-bounds access in get_imix_entries
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 5.15.0-1080.87~20.04.1 : patch Linux kernel soon.
Data as of 29 Oct 2026, 22:37 UTC
- Patch
- Available – fixed in 5.15.0-1080.87~20.04.1, 5.15.0-1086.95~20.04.1, 5.15.0-1081.90~20.04.1 +62
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 31 Jan 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-7387-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7388-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7389-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7390-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7407-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7421-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7445-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7448-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7458-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7459-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azure-nvidiapkg:deb/ubuntu/linux-azure-nvidia?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading to one of the fixed Linux kernel versions starting from 5.15.0-1074.77~20.04.1 or later as listed in the established facts. Users should update their Linux kernel packages to these fixed versions to remediate the vulnerability. No additional mitigation is required beyond applying the official kernel updates.
Description
CVE-2025-21680 is a high-severity vulnerability in the Linux kernel's pktgen module caused by an out-of-bounds array access in the get_imix_entries function. This flaw occurs due to incorrect boundary checking when processing imix entries, potentially leading to invalid memory access. The issue has been fixed in multiple Linux kernel versions starting from 5.15.0-1074.77~20.04.1 and later. No known exploits are reported in the wild. The vulnerability affects various Linux kernel versions prior to these fixed releases.
References
- ubuntu.com/security/CVE-2025-21680 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-21680 (opens in a new tab)
- git.kernel.org/linus/76201b5979768500bca362871db66d77cb4c225e (opens in a new tab)
- git.kernel.org/stable/c/1a9b65c672ca9dc4ba52ca2fd54329db9580ce29 (opens in a new tab)
- git.kernel.org/stable/c/3450092cc2d1c311c5ea92a2486daa2a33520ea5 (opens in a new tab)
- git.kernel.org/stable/c/76201b5979768500bca362871db66d77cb4c225e (opens in a new tab)
- git.kernel.org/stable/c/7cde21f52042aa2e29a654458166b873d2ae66b3 (opens in a new tab)
- git.kernel.org/stable/c/e5d24a7074dcd0c7e76b7e7e4efbbe7418d62486 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7388-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7389-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7390-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7387-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7407-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7421-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7445-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7448-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7458-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7459-1 (opens in a new tab)