Skip to main content
VulnerabilityPublished Updated

CVE-2025-21920: Linux kernel · vlan: enforce underlying device type

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.1 High · fixed in 5.4.0-1146.156~18.04.1 : patch Linux kernel soon.

Data as of 28 Oct 2026, 12:56 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.4.0-1146.156~18.04.1, 5.4.0-1151.158~18.04.1, 5.4.0-1149.158~18.04.1 +88
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-84.84
Fixed in
  • 6.8.0-84.84
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1039.41
Fixed in
  • 6.8.0-1039.41
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1038.44
Fixed in
  • 6.8.0-1038.44
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threatsAffected
  • <6.11.0-1018.18~24.04.1
Fixed in
  • 6.11.0-1018.18~24.04.1
Ubuntu 24.04 LTSlinux-azure-nvidiapkg:deb/ubuntu/linux-azure-nvidia?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1025.27
Fixed in
  • 6.8.0-1025.27
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1040.42
Fixed in
  • 6.8.0-1040.42

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in multiple fixed Linux kernel versions including 5.4.0-1146.156~18.04.1 and later. Users should apply the official Linux kernel updates provided by their distribution, such as the Ubuntu security notice USN-7510-1, and reboot their systems to ensure the fix is applied. No additional mitigation steps are required beyond applying the official patch.

Description

CVE-2025-21920 is a vulnerability in the Linux kernel's VLAN device initialization that allows VLAN devices to be created on non-ethernet devices, causing an out-of-bounds read and leaking a kernel function address to user mode. This occurs because multicast addresses used during initialization are only 6 bytes long, but the underlying device's address length can be greater, leading to memory disclosure. The issue is fixed by enforcing the underlying device type during VLAN device creation.

References

Community reviews

Loading reviews…