Skip to main content
VulnerabilityPublished Updated

CVE-2025-22004: Linux kernel · net: atm: fix use after free in lec_send()

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 8.6 High · fixed in 5.4.0-1147.157~18.04.1 : patch Linux kernel soon.

Data as of 28 Oct 2026, 12:45 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.4.0-1147.157~18.04.1, 5.4.0-1152.159~18.04.1, 5.4.0-1150.159~18.04.1 +86
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-84.84
Fixed in
  • 6.8.0-84.84
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1039.41
Fixed in
  • 6.8.0-1039.41
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1038.44
Fixed in
  • 6.8.0-1038.44
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threatsAffected
  • <6.11.0-1018.18~24.04.1
Fixed in
  • 6.11.0-1018.18~24.04.1
Ubuntu 24.04 LTSlinux-azure-nvidiapkg:deb/ubuntu/linux-azure-nvidia?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1025.27
Fixed in
  • 6.8.0-1025.27
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1040.42
Fixed in
  • 6.8.0-1040.42

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch addressing this vulnerability is available and should be applied promptly. Ubuntu has released fixed kernel versions (e.g., 5.4.0-1147.157~18.04.1 and others) that resolve this issue. Users should update their Linux kernel packages to these fixed versions and reboot the system to apply changes. Due to ABI changes, recompilation and reinstallation of third-party kernel modules may be necessary. No additional mitigation steps are required beyond applying the official fixes.

Description

A use-after-free vulnerability was identified and fixed in the lec_send() function of the Linux kernel's ATM networking subsystem. The flaw involved improper handling of the socket buffer (skb) length after the ->send() operation, which frees the skb, potentially leading to use-after-free conditions. This vulnerability affects multiple Linux kernel versions prior to the fixed releases. The issue has been addressed in updated kernel versions, and patches are available. The vulnerability has a high severity rating with a CVSS score of 8.6. No known exploits in the wild have been reported.

References

Community reviews

Loading reviews…