Skip to main content
VulnerabilityPublished Updated

CVE-2025-22039: Linux kernel · ksmbd: fix overflow in dacloffset bounds check

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 8.8 High · fixed in 6.8.0-1041.43~22.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-1041.43~22.04.1, 6.8.0-1041.47~22.04.1, 6.8.0-1042.45~22.04.1 +33
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux@6.8.0-86.87?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-86.87
Fixed in
  • 6.8.0-86.87
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws@6.8.0-1041.43?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1041.43
Fixed in
  • 6.8.0-1041.43
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure@6.8.0-1041.47?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1041.47
Fixed in
  • 6.8.0-1041.47
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11@6.11.0-1018.18~24.04.1?arch=source&distro=nobleOther threatsAffected
  • <6.11.0-1018.18~24.04.1
Fixed in
  • 6.11.0-1018.18~24.04.1
Ubuntu 24.04 LTSlinux-azure-fde-6.17pkg:deb/ubuntu/linux-azure-fde-6.17@6.17.0-1017.17~24.04.1?arch=source&distro=nobleOther threatsAffected
  • 6.17.0-1005.5~24.04.1 – 6.17.0-1017.17~24.04.1
4 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An official patch is available and should be applied to affected Linux kernel versions. The vendor advisory from Ubuntu confirms that this and other kernel vulnerabilities have been fixed. Users should update their Linux kernel packages to the patched versions as provided by their distribution.

Description

A vulnerability in the Linux kernel's ksmbd component was fixed to address an integer overflow in the dacloffset bounds check. The dacloffset field was originally a signed integer used in unchecked addition, which could overflow and bypass bounds checks, potentially causing out-of-bounds memory access and kernel crashes. The fix involved changing dacloffset to an unsigned integer and adding overflow checks. Multiple Linux kernel versions are affected, and a patch is available.

References

Community reviews

Loading reviews…