Skip to main content
VulnerabilityPublished Updated

CVE-2025-22079: Linux kernel · ocfs2: validate l_tree_depth to avoid out-of-bounds access

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.8 High · fixed in 5.4.0-1147.157~18.04.1 : patch Linux kernel soon.

Data as of 28 Oct 2026, 11:45 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.4.0-1147.157~18.04.1, 5.4.0-1152.159~18.04.1, 5.4.0-1150.159~18.04.1 +86
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-86.87
Fixed in
  • 6.8.0-86.87
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1041.43
Fixed in
  • 6.8.0-1041.43
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1041.47
Fixed in
  • 6.8.0-1041.47
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threatsAffected
  • <6.11.0-1018.18~24.04.1
Fixed in
  • 6.11.0-1018.18~24.04.1
Ubuntu 24.04 LTSlinux-azure-nvidiapkg:deb/ubuntu/linux-azure-nvidia?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1029.32
Fixed in
  • 6.8.0-1029.32

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in multiple Linux kernel versions, including 5.4.0-1147.157~18.04.1 and later. Users should update their Linux kernel to one of the fixed versions listed in the advisory and reboot their systems to apply the fix. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be required. Follow the vendor advisory instructions for updating and rebooting.

Description

A vulnerability in the Linux kernel's ocfs2 file system was fixed by validating the l_tree_depth field to prevent out-of-bounds access. The l_tree_depth field is a 16-bit value but must be limited to OCFS2_MAX_PATH_DEPTH to avoid invalid memory access, which could occur when reading from a corrupted mounted disk. This flaw affects multiple Linux kernel versions prior to the fixed releases. The issue has a high severity with a CVSS score of 7.8 and impacts confidentiality, integrity, and availability. A patch is available and included in various updated Linux kernel versions.

References

Community reviews

Loading reviews…