CVE-2025-2302: Advanced Woo Search (WordPress plugin) · Cross-site Scripting
Affects Advanced Woo Search (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.4 Medium · patch available : update Advanced Woo Search (WordPress plugin) when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 25 Mar 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| mihail-barinov Advanced Woo Search – Product Search for WooCommerce | Affected
| Fixed in– |
AI-suggested
A patch is available to remediate this vulnerability. Users of the Advanced Woo Search plugin should update to the fixed version beyond 3.28 as soon as possible to mitigate the risk. Until patched, restrict contributor-level access to trusted users only and consider disabling or limiting use of the aws_search_terms shortcode to reduce exposure.
Description
The Advanced Woo Search plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's aws_search_terms shortcode in all versions up to, and including, 3.28 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- wordfence.com/threat-intel/vulnerabilities/id/ef8fca84-3ea1-432f-8cfe-9a1d1f70fa6f?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/advanced-woo-search/tags/3.28/includes/class-aws-shortcodes.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/advanced-woo-search/tags/3.28/includes/class-aws-shortcodes.php (opens in a new tab)