CVE-2025-24368: cacti · SQL Injection
Affects cactiSource GCVE Database
Not known to be exploited · CVSS 6.9 Medium : upgrade to 1.2.29 when convenient.
Data as of 30 Oct 2026, 00:33 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 4.0 | 6.9 |
|---|
- Patch
- Available – fixed in 1.2.29
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Jan 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade cacti to 1.2.29.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Cacti cacti | Affected
| Fixed in
|
AI-suggested
Upgrade Cacti to version 1.2.29 or later, where this SQL injection vulnerability has been fixed. No other mitigation actions are specified or required by the vendor advisory.
Description
CVE-2025-24368 is a SQL injection vulnerability in the open source Cacti performance and fault management framework. The issue arises from insufficient input validation in automation_tree_rules.php, specifically in the build_rule_item_filter() function of lib/api_automation.php, allowing untrusted data to be concatenated into SQL queries. This flaw is fixed in version 1.2.29.