CVE-2025-26269: DragonflyDB Dragonfly · Integer Underflow
Affects DragonflyDB DragonflySource GCVE Database
Not known to be exploited · CVSS 3.3 Low : upgrade to 1.29.0 when convenient.
Data as of 4 Nov 2026, 01:43 UTC
Thin evidence
One scorer or none| CNA (mitre) | CVSS 3.1 | 3.3 |
|---|
- Patch
- Available – fixed in 1.29.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 17 Apr 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade DragonflyDB Dragonfly to 1.29.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DragonflyDB Dragonfly | Affected
| Fixed in
|
AI-suggested
Upgrade DragonflyDB Dragonfly to version 1.29.0 or later, where this vulnerability is fixed. No other mitigation is indicated.
Description
CVE-2025-26269 is an integer underflow vulnerability in DragonflyDB Dragonfly versions through 1.28.2. Authenticated users can trigger a denial of service by causing the daemon to crash via a Lua library command that references a large negative integer. The issue is fixed in version 1.29.0.