Skip to main content
VulnerabilityPublished Updated

CVE-2025-30007: hestiacp · OS Command Injection

Affects hestiacpSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 1.9.5 soon.

Data as of 8 Nov 2026, 14:20 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.18.8
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-07-13.

Patch
Available – fixed in 1.9.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.

What to do

Upgrade hestiacp to 1.9.5.

Affected software

ProductAffectedFixed in
hestiacphestiacpAffected
  • <1.9.5
Fixed in–
GitHubhestiacppkg:github/hestiacpOther threatsAffected
  • <1.9.5
Fixed in
  • 1.9.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade HestiaCP to version 1.9.5 or later, where this vulnerability is fixed. No other mitigation is required as the fix addresses the root cause of the command injection.

Description

HestiaCP versions prior to 1.9.5 contain an authenticated OS command injection vulnerability. This flaw allows low-privilege authenticated users to execute arbitrary commands as root by injecting a single-quote character into unvalidated DNS record types. The vulnerability arises from insufficient input validation combined with unsafe eval-based parsing, enabling full root code execution during DNS record creation. The issue is fixed in version 1.9.5.

References

Community reviews

Loading reviews…