Skip to main content
VulnerabilityPublished Updated

CVE-2025-31650: Apache Tomcat · Incomplete Cleanup

Affects Apache TomcatSource GCVE Database

0
Compare

Public exploit available (Exploit-DB) · CVSS 7.5 High.

Data as of 30 Oct 2026, 00:15 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 28 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by Apache Software Foundation

    , 28 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. First Exploit-DB entry (opens in a new tab)

    Apache Tomcat 10.1.39 - Denial of Service (DoS)

    , 38 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software Foundation Apache TomcatAffected
  • 8.5.90 – 11.0.0-M2
  • >=8.5.90 <=8.5.100
  • >=9.0.76 <=9.0.102
  • >=10.1.10 <=10.1.39
  • >=11.0.0-M2 <=11.0.5
4 affected builds
Fixed in–

AI-suggested

Users should upgrade to Apache Tomcat versions 9.0.104, 10.1.40, or 11.0.6 where this vulnerability is fixed. No other mitigation or temporary workaround is indicated by the vendor advisory.

Description

CVE-2025-31650 is an improper input validation vulnerability in Apache Tomcat affecting versions 8.5.90 through 8.5.100, 9.0.76 through 9.0.102, 10.1.10 through 10.1.39, and 11.0.0-M2 through 11.0.5. The flaw involves incorrect error handling of invalid HTTP priority headers that leads to incomplete cleanup of failed requests, causing a memory leak. This can result in an OutOfMemoryException and denial of service if exploited with a large number of such requests. Fixed versions are 9.0.104, 10.1.40, and 11.0.6.

References

Community reviews

Loading reviews…