CVE-2025-32151: BuddyForms (WordPress plugin) · Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File
Affects BuddyForms (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 2.10.4 soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.10.4
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 4 Apr 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade BuddyForms (WordPress plugin) to 2.10.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ThemekraftBuddyForms | Affected
| Fixed in
|
AI-suggested
Avoid exposing the vulnerable plugin to untrusted users or networks.
Description
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Themekraft BuddyForms buddyforms allows PHP Local File Inclusion.This issue affects BuddyForms: from n/a through 2.10.2.
References
- patchstack.com/database/Wordpress/Plugin/buddyforms/vulnerability/wordpress-buddyforms-plugin-2-8-15-local-file-inclusion-vulnerability?_s_id=cve (opens in a new tab)
- patchstack.com/database/wordpress/plugin/buddyforms/vulnerability/wordpress-buddyforms-plugin-2-8-15-local-file-inclusion-vulnerability?_s_id=cve (opens in a new tab)