CVE-2025-3469: Wikimedia Foundation MediaWiki · Cross-site Scripting
Affects Wikimedia Foundation MediaWikiSource GCVE Database
Not known to be exploited · CVSS 0.0 Low · fixed in 1.43.1 : update Wikimedia Foundation MediaWiki when convenient.
Data as of 30 Oct 2026, 00:16 UTC
Thin evidence
One scorer or none| CNA (wikimedia-foundation) | CVSS 4.0 | 0.0 |
|---|
- Patch
- Available – fixed in 1.43.1, 1.42.6, 1.39.12
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:N/SA:N/RE:M/U:GreenExploitation evidence
Disclosed: evidence found.
CVE published 10 Apr 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Wikimedia Foundation MediaWiki to 1.43.1, 1.42.6 or 1.39.12.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Wikimedia Foundation MediaWiki | Affected
| Fixed in
|
AI-suggested
The vulnerability affects versions before 1.39.12, 1.42.6, and 1.43.1. Users should upgrade to these fixed versions to remediate the issue.
Description
CVE-2025-3469 is a Cross-site Scripting (XSS) vulnerability in Wikimedia Foundation's MediaWiki software. It involves improper neutralization of input during web page generation in the file includes/htmlform/fields/HTMLMultiSelectField.Php. The issue affects versions before 1.39.12, 1.42.6, and 1.43.1.