CVE-2025-37815: Linux kernel · misc: microchip: pci1xxxx: Fix Kernel panic during IRQ handler registration
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium · fixed in 6.8.0-1046.49~22.04.1 : update Linux kernel when convenient.
Data as of 30 Oct 2026, 22:51 UTC
- Patch
- Available – fixed in 6.8.0-1046.49~22.04.1, 6.8.0-1051.57~22.04.1, 6.8.0-1046.53~22.04.1 +29
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 8 May 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-7594-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7594-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7594-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8031-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-8031-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-6 (opens in a new tab)
- ubuntu.com/security/notices/USN-8031-3 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and included in Linux kernel versions 6.8.0-1046.49~22.04.1 and later. Users should update to these fixed versions to resolve the kernel panic issue. No additional mitigation actions are required beyond applying the official fix.
Description
CVE-2025-37815 is a vulnerability in the Linux kernel's microchip pci1xxxx driver that caused kernel panics during IRQ handler registration. The issue was due to improper handling of interrupt requests, specifically involving the use of generic_handle_irq and handle_nested_irq functions. This flaw has been fixed in Linux kernel versions 6.8.0 and later.
References
- ubuntu.com/security/CVE-2025-37815 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-37815 (opens in a new tab)
- git.kernel.org/linus/18eb77c75ed01439f96ae5c0f33461eb5134b907 (opens in a new tab)
- ubuntu.com/security/notices/USN-7594-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7594-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7594-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8031-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-8031-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-6 (opens in a new tab)
- ubuntu.com/security/notices/USN-8031-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8052-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-7 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-8 (opens in a new tab)
- ubuntu.com/security/notices/USN-8052-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8074-1 (opens in a new tab)