Skip to main content
VulnerabilityPublished Updated

CVE-2025-37914: Linux kernel · net_sched: ets: Fix double list add in class with netem as child qdisc

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.8 High · fixed in 5.15.0-1088.95~20.04.1 : patch Linux kernel soon.

Data as of 28 Oct 2026, 11:30 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.15.0-1088.95~20.04.1, 5.15.0-1094.103~20.04.1, 5.15.0-1087.96~20.04.2 +63
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-100.100
Fixed in
  • 6.8.0-100.100
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1046.49
Fixed in
  • 6.8.0-1046.49
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14?arch=source&distro=nobleOther threatsAffected
  • <6.14.0-1009.9~24.04.1
Fixed in
  • 6.14.0-1009.9~24.04.1
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1046.52
Fixed in
  • 6.8.0-1046.52
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threatsAffected
  • 6.11.0-1008.8~24.04.1 – 6.11.0-1018.18~24.04.1
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. Ubuntu has released fixed kernel versions that address this vulnerability. Users should update their Linux kernel packages to the fixed versions listed in the Ubuntu security notices (e.g., USN-7649-1 and related advisories) and reboot their systems to apply the updates. Due to ABI changes, recompilation and reinstallation of third-party kernel modules may be required. No additional mitigations are specified beyond applying the official patches.

Description

CVE-2025-37914 is a high-severity vulnerability in the Linux kernel's network scheduler (net_sched) subsystem, specifically in the ETS (Enhanced Transmission Selection) queuing discipline when used with netem as a child qdisc. The flaw involves a double addition of the same classifier to a list due to reentrant enqueue callbacks, leading to memory corruption. This issue does not cause use-after-free but can compromise system stability and security. Multiple Linux kernel versions prior to fixed releases are affected. Official patches have been released by Ubuntu to address this issue.

References

Community reviews

Loading reviews…